Partial outage in one of the datacenters

Incident Report for Fax.Plus

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 20:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2026 - 18:08 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 18, 2026 - 17:24 UTC
This incident affected: Fax.Plus (Web Application, iOS Application, Android Application, Email to Fax, Google Add-on, Microsoft Word Add-in, Zapier Integration, REST Developer API), Dial.Plus (Web Application), Sign.Plus (Web Application, iOS Application, Android Application, Google Add-On, Microsoft Word Add-in, REST Developer API), and Infrastructure (Email Notifications, Push Notifications).